PXF Upgrade and Migration

When you upgrade your Greenplum Database system, you must perform some additional steps in order to bring your PXF configuration up to date.

There are two possible scenarios:

  1. Greenplum Database 5.x to 6.x upgrade or migration:

    • If you are using the gphdfs external table protocol to access data stored in Hadoop in your Greenplum Database 5.x installation, you must first migrate your gphdfs external tables to use PXF instead, since Greenplum Database version 6 removes support for the gphdfs protocol.
    • PXF actions are required if you choose a gpupgrade-based Greenplum Database 5.x to 6.x upgrade.
    • PXF actions are required if you choose to manually migrate from Greenplum Database 5.x to 6.x.
  2. Greenplum Database 6.x to 6.newer upgrade: You may be required to perform PXF upgrade actions when you upgrade from a previous Greenplum Database 6.x version. Note that different steps are outlined based on your PXF installation source: a manually installed rpm or deb package downloaded from Tanzu Network, or the PXF version included with the Greenplum Database Server installer in versions 6.18.x and older.

If you are upgrading a PXF rpm or deb installation independent of a Greenplum Database upgrade, refer to the PXF upgrade documentation.